DSL Outage - Western & Central Montana
Incident Report for Clearfly
Resolved
This incident has been resolved.
Posted Jul 18, 2020 - 13:01 MDT
Monitoring
All services restored as of 7:30 AM MDT on July 18.
Posted Jul 18, 2020 - 13:01 MDT
Update
Technicians for the transport carrier are still working to restore service.
Posted Jul 18, 2020 - 05:24 MDT
Identified
A transport carrier is experiencing an outage that is affecting all DSL customers in western and central Montana (LATA 648). We are holding for an ETR at this time.
Posted Jul 17, 2020 - 18:26 MDT
This incident affected: Data Network.